Chapter 11. 3.0.0 Upgrade notes

Table of Contents

Change to Names of Shared Libraries
SIP Bugfix Requires SIPServer Upgrade
open-ils.auth.login
RTL CSS Stylesheet
Multi-Time Zone Installations

The minimum version of PostgreSQL required to run Evergreen 3.0 is PostgreSQL 9.4. Evergreen 3.0 also requires OpenSRF 3.0.0 or later.

Change to Names of Shared Libraries

OpenSRF 3.0 changes how the shared libraries for services written in C are named. If upgrading from an earlier version of Evergreen, opensrf.xml should be edited so that shared library file names listed in the <implementation> tag start with "lib". For example,

            <open-ils.cstore>
                <language>C</language>
                <implementation>oils_cstore.so</implementation>

should be changed to:

            <open-ils.cstore>
                <language>C</language>
                <implementation>liboils_cstore.so</implementation>