Chapter 13. Upgrading the Evergreen Server

Table of Contents

Software Prerequisites
Upgrade the Evergreen code
Upgrade the Evergreen database schema
Restart Evergreen and Test
Review Release Notes

Before upgrading, it is important to carefully plan an upgrade strategy to minimize system downtime and service interruptions. All of the steps in this chapter are to be completed from the command line.

Software Prerequisites

  • PostgreSQL: Version 9.4 is recommended. The minimum supported version is 9.3.
  • Linux: Evergreen 2.12.0 has been tested on Debian Jessie (8.0), Debian Wheezy (7.0), Ubuntu Xenial Xerus (16.04), and Ubuntu Trusty Tahr (14.04). If you are running an older version of these distributions, you may want to upgrade before upgrading Evergreen. For instructions on upgrading these distributions, visit the Debian or Ubuntu websites.
  • OpenSRF: The minimum supported version of OpenSRF is 2.5.0.

In the following instructions, you are asked to perform certain steps as either the root or opensrf user.

  • Debian: To become the root user, issue the su command and enter the password of the root user.
  • Ubuntu: To become the root user, issue the sudo su command and enter the password of your current user.

To switch from the root user to a different user, issue the su - [user] command; for example, su - opensrf. Once you have become a non-root user, to become the root user again simply issue the exit command.